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ComXchange 14 Setup Guide 

Introduction 
ComXchange is an all-inclusive communications server that includes a PBX, Call Accounting, and Voicemail 

developed specifically for the hospitality industry.  ComXchange leverages the power of hardware and 

software open standards.  This lowers costs and improves quality, providing the flexibility to provide 

customers with systems suited for large or small properties.  ComXchange is also carrier agnostic and allows 

for multiple carrier options such as T-1/PRI, SIP and POTS providing great flexibility.  

Hardware Architecture Overview: 
 

 

A ComXchange Setup will typically consist of these items: 

ComXchange Controller: 
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The ComXchange controller is a custom designed server platform. It runs headless as a server and therefore 

will not require a keyboard, mouse, or monitor.  While there is a monitor port, typically nothing is being 

transmitted on it.  The Controller hosts a Voice over IP (VoIP) PBX system that uses the internet standard for 

real-time voice communication SIP (Session Initiation Protocol) to deliver voice communications to other SIP 

devices. 

The ComXchange Controller provides: 

• Phone Extensions for Staff and Guests 

• Voicemail for Staff and Guests 

• Endpoint management for IP phones 

• DHCP Services that dynamically provides IP addresses for IP Phones 

• NTP Services that provides time synchronization for Network Devices 

• Hospitality Features and Interfaces.  

ComXchange Ports 
 The cabling of the ComXchange controller and where the USB drives are plugged in is very important for 

services to function properly.  Below is an overview of the ports that are typically used in a ComXchange setup. 

  

• PMS Serial Interface – Communicates between the PMS and the PMS Interface on the Controller for 
populating guest names on extensions upon check-in, wake up calls, and room status changes. 

• USB Storage Drive – A USB device in the lower left USB port will be used to store backups.  The other 
USB ports are available for USB to serial adapters if necessary.  

• LAN Ethernet Port – The Local Area Network (LAN) port will be connected to the local phone network. 

• WAN Ethernet Port – The Wide Area Network (WAN) port will be connected to a port with access to 
the internet for VPN connection, NTP, or a direct SIP connection.  

• CAS Serial Port – Communicates between the PMS and the Call Accounting Server on the Controller. 
 

Ethernet Switch 

 

Switches connect the components of the ComXchange phone system together via ethernet.  These are a vital 

part of the system and must meet specific requirements which include: 

• Management Interface 

• VLAN Tagging and Trunking 

• Quality of Service (QoS) for Voice Traffic Prioritization 

• Port mirroring for Troubleshooting 

• Gigabit backplane  

• PoE Capabilities 
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24-FXS Gateway 

 

The 24-FXS analog gateway provides connectivity to all industry standard analog phones.  Phones can be 

connected directly to the front with a cable or more commonly by an Amphenol cable which is tied into a 

punch down block.  The gateway provides dial tone, battery current, and ring voltage for an analog phone and 

will translate signals between analog and digital allowing communication to a VoIP server. 

VoIP Gateway 

 

 

The Voice Over Internet Protocol (VoIP) gateway provides a connection between the ComXchange Controller 

and standard Plain Old Telephone Lines (POTS) or the T1/ Primary Rate Interface (PRI) trunks provided by the 

telephone carrier.   The VoIP gateway provides a sip trunk connection to the ComXchange server over the 

ethernet port and a connection to the carrier trunk over the T1 0/2 port for a PRI - T1 connection or the voice 

port via an Amphenol cable for POTS Lines. 

Phones 

     

• IP Phones – Internet Protocol (IP) Phones make and receive calls over an IP Network, providing 
excellent voice quality.  IP phones also offer advanced functionality for programming buttons and xml 
applications 

• Analog Phones – provide basic calling functions mainly used in guest rooms and can have 
preprogrammed buttons that may need to match feature codes in the ComXchange Controller. 
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UPS 

 

An Uninterruptable Power Supply (UPS) provides battery backup to the system in a power outage.  All system 

components should be connected to a UPS as noted in the warranty information of the ComXchange System 

System Architecture 

 

Network Guidelines 
Because ComXchange is an IP based system, the network it resides on is very important.  All voice equipment 

must be on its own network.  This means using a separate physical network or at a minimum a VLAN 

containing only the voice equipment. 
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Example Switch Setup  

  

Default IP Address Scheme 

 

DHCP Server 
The ComXchange Controller has a built in DHCP server that will hand out addresses to devices with DHCP 

enabled.  The DHCP server has Option 160 enabled pointing to the controller which allows a phone to 

automatically find the provisioning server where the configuration is stored.                                                     

Admin > System Settings - DHCP 
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ComXchange Configuration 
Basic System Setup 
Once the equipment is cabled and turned on, connect a PC or a laptop to the voice network with an ethernet 

cable.   ComXchange is now ready to be configured in the ComXchange PBX system web GUI (Graphical User 

Interface).  Begin by logging into the Controllers web GUI, change the dealer password, verify/change the 

network settings of the controller, and make any changes to the SIP settings for your setup. 

Note: The ComXchange Controller must connect to the license server over the internet for activation.  If the 

Controller is not able to reach the license server, the ability to make configuration changes may fail. 

Logging In 

The web interface is accessible at 

http://192.168.101.2 by default. 

Click on PBX Administration and login with the 

default username/password of dealer/dealer.  

 

The controller will open the ComXchange status page and from here, you will have access to the configuration 

menu buttons across the top. 
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Changing the Dealer Password 

Navigate to Admin > Administrators.  This opens the Add administrator page.  On the right-hand side is a flyout 

menu with a list of current Users.  

1. Click on the flyout menu 
2. Click on dealer 
3. Enter the new password 
4. Click Submit Changes 

 

 

Network Settings 

Navigate to Admin > System Settings – Network Interfaces 

1. Click on Network Settings in the fly away menu on the right side of the page  
2. Ens160 (LAN) will be your local network with the default IP address  
3. Ens192 (WAN) is where you will set your static ISP IP address 

a. Click on the edit Actions icon for ens192.    
b. Make any adjustments, then click on the Update Interface & Restart Network button 
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Time Configuration 

Navigate to Admin > System Settings - Time 

1. Verify the Server time  
2. Adjust Time Zone, Date, and Time if necessary 
3. Click on Submit 

 

NTP Configuration 

Navigate to Admin > System Settings - NTP   

1. Verify that the Server time  
2. Verify Time Servers 
3. Make any adjustments to Client networks 
4. Click on Submit 
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SIP Settings 

Navigate to Admin > SIP Settings - Nat Settings 

1. Verify that the External IP reflects the static IP or Network Address Translation (NAT) IP address that 
can reach the public provider. 

2. Verify that the local network address matches any local networks and adjust if necessary.   

 

Power Options 

After making any changes to the networking be sure to submit and apply the changes to the configuration and 

as a best practice reboot the server. 

Navigate to Admin > System Settings - Power 

1. Click on Reboot 
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Core Configuration 
Setup internal calling.  To set up and test internal calling we will create Extensions with Voicemail, add a Ring 

Group that includes the new extensions, add a miscellaneous application for the operator then set up phones 

that will use these extensions. 

Building Extensions for Staff 

Navigate to Core Configuration > Extensions.  Here you can create Extensions 7000 and 7001 

1. Click on the Add Extension button 
2. Fill in the User Extension 
3. Fill in Display name 
4. You can fill in an optional outbound Caller ID (number) 
5. Make note of the secret field for use setting up a phone later 
6. Under the Voicemail Tab click on yes to enable Voicemail 
7. Enter a voicemail password 
8. Under the Advanced Tab - Optional Destinations other voicemail options can be configured 
9. Click on Submit and Apply Config 
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Add Extensions 7001 (Front Desk2) which will be added to a ring group in the next section and 7002 (MOD) to 

be used as a back of house phone for later testing. 

  

Ring Groups/Operator Routing 

The Operator Ring Group will be available by default. Any extensions that are in this group will ring when 600 

is dialed.  Note: It is possible to add an external number to a ring group by typing the number followed by #.  

Navigate to Core Configuration > Ring Groups. 

1. Click on the Ring Group 600 edit Actions button on the right side 
2. Add Extensions 7000 and 7001 in the User Quick Select Dropdown 
3. Click on Submit at the bottom of the page and Apply 
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Miscellaneous Application 

Creating a miscellaneous application will create a feature code that when dialed can point to destinations 

available in ComXchange, such as a Ring Group.  Below shows the process of adding a Misc Application called 

Operator that allows 0 to dial the Front desk Ring Group 

Navigate to Advanced Configuration > Misc Applications.   

1. Click Add Misc Application 
2. Fill in a Description “Operator” 
3.  Fill in Feature Code Number “0” 
4. Choose a Destination 
5. Submit Changes and Apply Configuration 
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Miscellaneous Destination 

A Miscellaneous Destination will allow calls to be routed from another module by simulating a number being 

dialed, such as a feature code or an external number to reach an outside reservations office or a mobile 

phone.  These are often used in combination with a Misc Application, IVR’s, or Speed Dials. 

Create a Destination to an External Phone Number. 

Navigate to Advanced Configuration > Misc Destinations.   

1. Click on the Add Misc Destination button 
2. Add a Description 
3. In the Dial Field insert numbers exactly as you would dial them from a phone 
4. Submit and Apply 

 

 

This can now be used as a destination for an IVR, an Inbound Route, or a Speed Dial. 

Basic IP Phone Configuration 
IP phones can be setup in two ways.  Phones can be provisioned by the server where a configuration is created 

from a template for a phone’s MAC Address which will automatically download from the network or they can 

be (hardcoded) which involves configuring the individual phone via the individual phone’s web GUI. 

Endpoint Provisioning 

Navigate to Core Configuration > End Point Manager 

1. Click on Settings in the Endpoint Manager fly away menu on the right 
2. Verify the IP address of the phone server 
3. Verify the Time Zone 
4. Verify the NTP server information (can point to ComXchange) 
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End Point Templates 

Templates are an easy way to deploy phones that will have similar functionality such as a front desk phone.  

Phones based on these templates will have the same buttons on the display, dial plan information, and any 

other specific information added to the template.  Phones will typically check for config changes on bootup. 

Navigate to Core Configuration > End Point Manager – Template Manager (fly away menu) 

1. Click on Add New Template 
2. Fill in the Template Name 
3. Choose from the type of phone from the drop-down menus 
4. Choose a template that you would like to clone from  
5. Click on Save 
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 Mapping an Extension to a Phone Device 

You can map an extension to a phone device from ComXchange in one of two places.  In the Extension settings 

or in the End Point Dashboard.  Either way you will need the MAC Address from the phone which is usually 

located on the back of the phone. 

Extension Settings 

Navigate to Core Configuration > Extensions 

1. Click on the edit Actions Button of the extension you are adding a device to 
2. Click on the Other tab 
3. Fill in the MAC Address 
4. Choose the Brand of phone 
5. Choose the Model of phone 
6. Choose the line for the extension number (default is 1) 
7. Choose the Template to apply to the phones configuration 
8. Click on Submit and Apply 

 

  

End Point Dashboard 

Navigate to Core Configuration > End Point Manager – Extension Mapping (fly away menu) 

1. Fill in the MAC Address, Brand, Model of phone, the extension number and the template to use 
2. Click on Add 
3. Click on Rebuild 
4. Connect the phone to a Power over Ethernet (POE) switch port or reboot the phone  
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As changes are made to the templates you can click on Rebuild and check the Reboot Phone check box to 

force the phones to download the new configuration. 

 

You should now see the devices appearing as up by in the Current Managed Extensions in the End Point 

Dashboard which means they have registered to the ComXchange Controller. 

 

You can also verify the phones are registered by navigating to Reports > Asterisk Info – Peers, where you will 

get a list of the devices registered to the phone server. 
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Test Internal Calls and Voicemail 

1. You can now make calls from extension to extension 
2. Test the “Operator” Misc Application by dialing 0 from extension 7002 and verifying that it rings both 

7000 and 7001 via the Ring group 600. 
3. Dial the Voicemail Feature Code *55 to change the default greeting and password 

IP Phone Customization 

Common Features that are customized in IP Phones are Busy Lamp Field (BLF) buttons, Voicemail Speed Dial 

buttons, Parking and setting up Dial Plan Rules.  These can be pushed out to phones by using a template.  

Navigate to Core Configuration > End Point Manager – Template Manager (fly away menu) 

• Click on the edit icon of the template you would like to customize, scroll down to keys and dial plan 

 

Keys 

Keys are related to the buttons whether physical or soft buttons on the phone screen.  They can be configured 

to perform many different actions.  Below is a list of some of the common keys. 

• Busy Lamp Field (BLF) buttons monitor the state of another extension/feature and can be used to dial 
the extension when the extension is idle.  Typically, a BLF will do direct pickup when ringing if 
monitoring an extension. 

• Speed Dials can be set to dial a number 
o Note: if a ringroup has call pickup enabled a speed dial of **<EXT> can pickup that ring group 

• You can set a key to direct dial voicemail 

• Park is a built-in feature code that allows you to place calls on hold in up to 8 slots that can be picked 
by other extensions 

• You can also create speed dials to connect to an application to do basic wakeup call and guest 
management 
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Dial Plan 

Dial plans are needed to be able to dial numbers without a timeout.  Full documentation on dialing rules can 

be found in the phone’s administration Guide.  Below are examples from an Aastra Dial Plan and the Yealink 

Dial Now Rules. 

Aastra 

 

90x+#|9[2-9]xxxxxx|91[2-9]xxxxxxxxx|911|9[2-9]11|0|[1-6]xx|7xxx|*5x|x+# 

Yealink 

 

Trunking Overview and Setup 
• Trunks are delivered to the ComXchange using Session Initiated Protocol (SIP) 

• T1,PRI, POTS are “converted to SIP using a VoIP gateway. 

• Direct SIP Trunks are usually routed to the ComXchange controller on the eth1/WAN interface.  

Configuring a Trunk 
Navigate to Core Configuration > Trunks - Click on Add Trunk  

• Choose add SIP (chan_sip) Trunk 
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Direct SIP Trunk 

1. Under the General Tab, fill in the Trunk name (descriptive name), and Outbound CallerID 
2. Under the sip Settings – Outgoing Tab, fill in the Trunk Name, Peer Details 
3. Under the sip Settings – Incoming Tab, add the Register String 
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If there is connectivity with the SIP Provider or Gateway and the Trunk settings match on both sides of the 

trunk, you should now be registered to a host which can be verified in Reports > Asterisk Info – Registries. 

 

Trunk to Gateway 

When you are using a VoIP Gateway the ComXchange and the gateway will connect over the LAN connection.  

The Settings will be very similar to a direct SIP connection however you will not need a registration string. 

1. Under the General Tab, fill in the Trunk name (descriptive name), and Outbound CallerID 
2. Under the sip Settings – Outgoing Tab, fill in the Trunk Name, Peer Details 
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Inbound / Outbound Routing Overview 
Inbound phone calls are routed to extensions when incoming dialed digits match a rule telling the 

ComXchange which extension should receive the call.  Outbound calls must also match rules that tell the 

ComXchange where to send the call, whether it is an internal call or one that should go out a Trunk.  These 

rules are setup as Inbound and Outbound routes.  

Inbound Routes 
A telephone carrier will direct calls to a property based on a telephone number.  There can be multiple Direct 

Inward Dialing (DID) numbers that point to the main phone number.  To receive calls ComXchange must know 

where to route them.  Below we will set up a catchall route that will send all calls to the Operator Ring Group.  

Catchall Route 

Navigate to Core Configuration > Inbound Routes. 

1. Click on Add Inbound Route 
2. Leave the DID number field blank.  Which means any calls with or without a DID will match. 
3. Set the Destination to Ring Group to Operator 600 
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Outbound Routes 
ComXchange has default outbound routes prepopulated with dial patterns that need to be associated with a 

Trunk.  Each of these routes will need to be associated with a Trunk for calls to be directed to a telephone 

provider.  Order is important.  For example, toll free should be before long distance. 

Navigate to Core Configuration > Outbound Routes 

1. Open each route by clicking on the edit Actions icon 
2. Choose the Trunk you want for each of Outbound Route  
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Dial Patterns  

ComXchange uses dial patterns to match dialed digits.  You can use the below dial pattern rules to set up 

unique routes, however, ComXchange has common default routes already set up for you in the Outbound 

Routes Dial Pattern tab. 
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Navigate to Core Configuration > Outbound Routes – Dial Pattern tab 

Click on Each of the Routes 

Default Dial Patterns have a prefix that is needed to dial out then stripped before sending to the trunk  

Emergency 

 

Local 

 

TollFree 

 

LongDistance 

 

International 

 

Outside operator 

 

Outbound Caller ID Considerations 

• Caller ID (CID) can be set in Extensions, Outbound Routes, and Trunks.   

• CID set in Extensions override Outbound Routes (unless override extension is checked) in the Trunk 

• CID on Outbound Routes overrides CID set in Trunks. 

• Trunk Caller ID is used as a last resort.  If only one number is being sent from the system, typically just 
set the CID at the trunk level. 

Test Calls 

Calls can now be made to and from the ComXchange.  You can now make a test call from one of the phones.  

Change the Caller ID on Extension 7002 to 6087731055 and place a call to see the CID change. 
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Emergency Notification Overview 
There is an Emergency Outbound route set to match emergency dialing patterns such as 911.  By selecting the 

Emergency Route Type Box any calls matching the dial patterns will also trigger a notification to be sent to the 

destinations set in the Emergency Notifications Settings Module. 

Emergency Outbound Route 

 

Emergency Notifications Settings   
A notification phone call and or email can be sent when a call is made on an outbound route designated as an 

emergency route.   The notification will contain the extension that dialed 911. A call notification must be 

answered and acknowledged by pressing 1. 

Navigate to Admin > Emergency Notifications  

• Add a Number to Notify - If a 911 call is placed this number will be notified 

• Add Email Address or Addresses separated by a comma 

 

Guest extension Overview 
General Settings 
This is where the Global SIP password for guest extensions is set.  You will also find the Room Status/ 

Housekeeping feature code and the Guest Voicemail Access Code.   

Navigate to Guest Management > General Settings. 

• The Guest SIP Password is a universal password that guest phones use to register to the guest system 

• The Guest Extension Routing option allows you to choose an action for an inactive mailbox. 
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Guest Extensions 
• Extension Range Creation creates extension(s) and assigns them to a room. 

• The room number is the field used in communications with the PMS system. 

• The room number can be left blank if it matches the extension 

• Guest extension with the same room number will share a mailbox and ring all phones  
Navigate to Guest Management > Guest Extensions 

1. Click on Add Guest Extensions 
2. Enter Extension Start: 100  
3. Enter Extension End: 121  
4. Enter 100 for Room Number Start 
5. Submit and Apply Config 

 

 

The Created Guest Can be viewed in the right side fly away menu.   
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You can click on an extension to verify the room number and make any changes. 

 

Guest Speed Dials 
Guest Speed Dials can be set to match the speed dial buttons programmed on many analog guest phones.  The 

phone buttons will be programmed specifically for a phone by the manufacturer.  

Navigate to Guest Management > Guest Speed Dials - [Speed Dial Number] 

• Click on the edit Actions icon to edit a speed dial or you can add a Guest Speed Dial  

• Speed Dial Code is what the manufacturer programmed into the phone 

• Number is the digits a call is forwarded to when it receives a Speed Dial Code 

 

 

Wake Up Calls 
Wake up calls can be created through the Hotel Dashboard, using the Guest Console phone App and directly 

dialing a feature code.  Wakeup call settings and logs can be found in Guest Management > Wakeup Calls  

Wakeup Call Settings 

• Navigate to Guest Management > Wakeup Calls 

• You can change the default Wakeup Call Settings for ring duration, call attempts, allowing snooze, etc 

• The Failure Calls Settings tab allows you to set an extension to notify if a wakeup call is not answered 
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Call Settings 

 

Failure Call Settings 

 

Wakeup log  
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Guest management Wakeup Feature Codes 

There are Guest management feature codes that can be directly dialed to set Wakeup Calls and 

Announcements. 

 

Analog Guest Phones 
Guest phones are typically analog phones, these phones translate an audio signal into electronic pulses that 

travel across a phone line to another analog device.  Because ComXchange communicates using VoIP the 

analog signal must be translated by an FXS Gateway into a digital VoIP call to be processed by the 

ComXchange Phone System.  The gateway will have ports/connections that provides dial tone, battery current, 

and ring voltage for an analog phone.  The gateway will also have a port that connects to an IP network for 

VoIP communication.  Any calls made to or from an analog phone connected to a gateway will be translated 

from analog to digital or digital to analog making communication possible. 

ComXchange Gateway Configuration 
To configure a ComXchange gateway you will first need to find the IP address.  Gateways will be shipped with 

DHCP enabled on them.  They will need to be plugged into the switch to get an IP address.  You can find the IP 

address by plugging an analog phone into the gateway and dialing *** or look in the dhcp leases in Admin> 

System Settings > DHCP Server -leases.  Type the IP address into the address bar of a browser to bring up the 

web GUI. 

Password 

Default username and password is User Name: admin and Password: password.  

 

Navigate to System > System Preferences > Password Settings to change the password. 
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Set IP Address 

Navigate to System > LAN Settings 

1. Change the IP address information.  In the addressing scheme 192.168.101.21 can be used as the first 
gateway IP address. 

2. Save the changes.   
3. Reboot the gateway 
4. Log into the web GUI using the new IP address. 

 

Voip Servers 

Navigate to Gateway > Voip Settings > VoIP Server Settings 

1. Click on Edit VoIPServer1 
2. Edit the Server Name to ComXchange (or other)   
3. Enter 192.168.101.2 in the Hostname/IP field and save then Apply Change 
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Dial Plan 
Like IP phones; gateways have their own dial plan configuration setup to match patterns that can be dialed without a 

timeout. Navigate to Gateway > Voip Settings > Dial Pattern Template 

1. Click on Edit for DialPatternTemplate1 
2. Edit the name to CommonDialing 
3. Set Dial Patterns for 0, 911, [8-9]911, [8-9], [2-9]xxxxxx, [8-9]1[2-9]xxxxxxxxx, [8-9]011., [1-9]xx,7xxx, 

*2, *1, *[3-9]x 
4. Click on Save 
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Extensions/Ports 

A port on a gateway acts as a proxy SIP device for an analog phone.  You will need to associate an extension on 

the phone server with a port on the gateway much like setting up an extension on an IP Phone.  Below are the 

settings needed to register a port with extension 7100 to the ComXchange controller which will allow the 

gateway to translate calls to an analog phone connected to the port.  

1. Click on Edit Port 
2. Set the Caller ID Name, Caller ID Number, Username, and Authentication Name and DID Number field 

to the extension number (7100). 
3. In the VoIP Server dropdown choose the Guest PBX. 
4. Fill in the SIP password that was created in the Guest General settings in the ComXchange. 

a. Guest Management > General Settings > Guest SIP Password 
5. In the Dial Pattern Template dropdown associate a dial pattern for the device. 

 

The other tab has additional extension settings can be set including the MWI light. 
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MWI Settings 

1. Set Subscribe to MWI to Yes. 
2. Set MWI Light Option to neon. 

 

Add extension 7101 on port 2 with the same settings.  You can now call from 7101 (room 101) to 7100 (room 

100) and they can both dial 0 to get to the operator queue.  

HotLine 

A hotline can be used by an extension such as a lobby phone to automatically dial a number such as 0 (the 

operator group).  To do this you will need to add an extension for the Lobby phone on the Business PBX and 

set the gateway port to use that Extension and the Staff VoIP Server then enable the hotline. 

Add Staff Lobby Phone extension 
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On the gateway port match the extension properties to register the port, then set the Hotline Settings. 

1. Set Enable Hotline to Yes 
2. Set the Hotline Number to 0 
3. Adjust the Delay Dial if necessary 

 

 

Guest Management Interfaces 
ComXchange interfaces with leading Property Management Systems for both room status and call accounting.  

Communication between the systems takes place over a serial connection.  The settings for these can be 

found in Guest Management > Interfaces.  Here you can also view the interface logs allowing you to verify the 

information sent to the PMS over the PMS interface and SMDR (Station Messaging Detail Records) logs sent 

from the PBX to the Call Accounting Server where call costs are processed then sent from the Call Accounting 

server to the PMS.  

PMS Interface 
The PMS interface can connect with a PMS system to send and receive information.  The ComXchange server 

can send Room Status updates that are keyed in at the guest rooms and the PMS can send Check-in 

information and call restrictions to the ComXchange server.  In ComXchange 14 you can create and manage 

interfaces to connect to multiple PMS systems this is necessary when dealing with dual branded properties. 

Navigate to Guest Management > Interfaces – Click on the PMS edit Actions icon.   
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Here you can Start and Stop the interface or Request a Resync. 

 

PMS General Tab 

In the General tab you can enable the interface and setup the Protocol and Connection settings  
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PMS Message Options Tab 

Message options are the types of data “messages” that make up the language sent between the PBX and the 

PMS systems interface so they can communicate.  Some PMS systems do not understand all the messages 

which can cause communication problems.  In this tab you can choose which message are enabled, disabled, 

or if they are expected to be inbound or outbound messages. 
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PMS Log Tab 

The PMS Log will show information that is exchanged between the PMS and the ComXchange Phone System.  

When the Interface is started the ComXchange PMS Interface will send out an ENQ message and will expect to 

receive an ACK message from the PMS System.  This acknowledgement is the first sign the 2 sides are 

communicating. 

 

SMDR Interface (Call Accounting) 
The SMDR interface monitors the Station Message Detail Recording (SMDR) records and captures detailed 

information about incoming and outgoing voice and data calls.  This information is sent to the call accounting 

server for analysis.  If Call Accounting determines there is a charge for a call the charge information is sent out 

the CAS Serial port to the PMS.  

Navigate to Guest Management > Interfaces – Click on the SMDR edit Actions icon.   

 

Here you can Start and Stop the interface or Request a Resync  
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SMDR General Tab 

In the General tab you can enable the interface and setup the Protocol and Connection settings  
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SMDR Message Options Tab 

Message options are the types of data “messages” that make up the language sent between the PBX and the 

PMS systems interface so they can communicate.  Some PMS systems do not understand all the messages 

which can cause communication problems.  In this tab you can choose which message are enabled, disabled, 

or if they are expected to be inbound or outbound messages. 

 



41 
COMXCHANGE 14 

SMDR Log Tab 

The SMDR Interface Logs show you the information that the Call Accounting Server received from the PBX.   

Only when the Call Accounting Server receives a SMDR that has a charge is it sent to the PMS System over the 

CAS serial port. 

 

Serial -To -IP (IPOCKET) Device Settings 
Communication Between the PMS System and both the PBX and Call Accounting Interfaces can also take place 
over a Serial to IP Device.  To Configure an IPOCKET Press and hold reset button on IPOCKET to access settings 
via the serial port of the unit.  Set monitoring software on laptop to 9600-N-8-1. 
 

 

Hotel Dashboard 
There is a web GUI that staff can use to manage wakeup calls, change a room’s calling permissions, and 

override room status to allow for a checked-out room to place calls.  The Hotel Dashboard is accessed through 

the ComXchange UCP (User Control Panel) with a user that is created in the User Management Module.  Note: 

ComXchange Admins can access the Hotel Dashboard through Reports > Hotel Dashboard. 
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Create a User  
To access the Hotel Dashboard, you need a user that has access to the UCP.  While this can be an extension 

User that is given access in the example below, we will create a User that is dedicated to access the Hotel 

Dashboard. 

Navigate to Admin > User Management 

1. Choose any extension and click on the edit Action icon 
2. Click on and open the Flyout Menu  
3. Click on the Add User Button 
4. Fill in the Login Name 
5. Fill in a Password 
6. Submit and Apply 
7. Click on the edit Action icon of the new user 
8. In the UCP tab click on the Yes button to allow Login 
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Login into the Hotel Dashboard 
You can use the newly created dedicated Hotel Dashboard User to login to the Hotel Dashboard. 

1. Enter http://192.168.101.2/UCP in a browser.   
2. Login with the username and password. 
3. Click on the Hotel Dashboard Link 
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Guest Extension Management 

In the Guest Extension Management Tool you can verify and change the status of the guest extension state as 

it appears to ComXchange.   This can be helpful when testing guest extension calls.  Making changes in the 

Check-In State for a room with this tool only makes it appear checked in to ComXchange It does not push 

anything to the PMS. 

 

Bulk Wakeup Tool 

The Bulk Wakeup tool Allows you to create wakeup calls for a single or multiple guests. 

Navigate to Tools > Bulk Wakeup Tool 

 

Set Wakeup Call 

1. Enter the Room(s) number(s)  
2. Set the time for the wakeup call 
3. Choose if this should be reocurring for the guests stay 
4. Click on Set Wakeups 
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Remove Wakeup Call 

Navigate to Tools > Guest Extension Management 

1. Click on the Wakeup Call Button for the extension you want the wakeup call removed 
2. Click on the Delete icon 
3. Click on the Yes button to confirm 
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Guest Reports 

In the Guest Tool Console there is a reports menu where a user can view reports on Emergency Notification 

Calls that have been placed and a report of Wakeup Calls that are Pending, Completed, or Failed.   

 

Emergency Notification Report 

 

Wakeup Reports 
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Hotel Dashboard Widget 

You can launch the Hotel Dashboard through a widget created in the UCP 

1. Click the Add Dashboard Button 
2. Name the Dashboard 
3. Click the Add Widget Button 
4. Click on the Hotel Dashboard Widget 
5. Click the Add button  
6. Click the Launch Hotel Dashboard Button 
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Attendant Console 
Models of Aastra and Yealink Phones can be programmed to be Attendant Console Phones.  The Console can 

Pick-up, Park, Transfer calls, manage Night Mode, etc.  It is also possible to manage Wakeup Calls as well as 

Guest Room Moves, DND Settings, and Call Restrictions.  There are default Front Desk Phone Templates 

available on the ComXchange server that have many of these features configured in the Keys section.  These 

can be set up by adding keys to other phone templates as well. 

Attendant Console Keys Examples 
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Guest Console TUI (Text-Based User Interface) Phone Applications 
There are two hospitality applications that are used by the Attendant Console. The Guest Management App 

and the Guest Wakeup App.  

  

Guest Management App 

1. Press the Guest Management App Button 
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2. Enter a Room Number - press Submit 
3. Choose an action, for instance press 3 for DND - press Select 
4. Select by number, DND On or Off then press Select 

   

 

 

Wakeup App 

1. Push the Wakeup App 
2. Enter a Room Number - press Submit 
3. Enter a Wakeup Time - press Submit 
4. Choose to Repeat or Do Not Repeat - press Submit 
5. Choose Confirm or Start Over – press Submit 
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System Recordings/Prompts 
The System Recoding Module allows the creation of prompts or announcements from any phone or an 

uploaded file.  If uploading a file, it must be in the correct format.  [Wav PCM Encoded, 16 bits, at 8000Hz].  

You can enable a feature code on a recording to allow easy access to re-record. 

Navigate to Advanced Configuration > System Recordings 

Upload a Recording 
1. Click on the Add Recording Button 
2. Enter a Name for the recording 
3. Enter a Description of the recording 
4. Upload the Recording.   

a. Drag the File to the Browser or Browse to the File by Clicking Browse 
5. Submit, Click OK on the Popup, and Apply 
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Record Over an Extension 
1. Click on the Add Recording Button 
2. Enter a Name for the recording 
3. Enter a Description of the recording  
4. Enter extension 7000 to set a recording from a phone extension 
5. Click on Call 

a. The phone System will Call the Extension and beep 
b. Record the Message and Hang up 

6. The Record Over Extension Field changes to “Name this file” 
7. Enter a name for the file 
8. Click Save 
9. Click Submit and Apply 
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System Recording Feature Code 

1. Click on the Edit Actions Button of the Recording you want to assign a Feature Code 
2. Link the Feature Code by selecting Yes 
3. Enter a password for the Feature Code if desired  

 

 

You can now dial the feature code to access the recording.  This recording is now available to be used by IVRs, 

Queues, or Announcements.   
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IVR Setup 
Interactive Voice Response (IVR) is a technology which allows callers to navigate a phone system before 

talking to an operator or other destinations on the phone server.  An IVR can be set to other system modules 

and can be nested.  The IVR can be linked to a directory to allow selective extension dialing.  You can choose in 

the IVR menu what happens if a wrong key is pressed or if a caller doesn’t press a key within a timeout period. 

Below we will set up an auto attendant IVR that allows a caller to choose to go to the operator leave a 

voicemail or be directed to extension 7000.  For this to work you would need to record a greeting that offers 

these options to the caller.  

Create The IVR 
Navigate to Core Configuration > IVR. 

1. Click on the Add IVR Button 
2. Enter an IVR name and description 
3. Choose the recording to use as an announcement 
4. Set the amount of time with no key press to be considered a timeout 
5. Set your invalid retries, the number of invalid key presses allowed before going to Invalid Destination 
6. Choose a recording to play when an invalid key is pressed 
7. Choose to play the IVR announcement again when an invalid key is pressed 
8. Choose a recording to play before sending a caller to an invalid destination 
9. Choose a destination to send the caller when the number of invalid retries is reached 
10. Choose the number of times out retries before sending the caller to the timeout destination 
11. Choose a recording to play if a caller reaches a timeout  
12. Choose whether to play the IVR the main announcement after a timeout 
13. Choose a destination to send callers after a timeout limit is reached 
14. Declare your IVR entries 
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Create a Misc Application to the IVR 
Create a new Misc Application to point to the Auto Attendant IVR. 

Navigate to Advanced Configuration > Misc Applications 

1. Click on the Add Misc Application Button 
2. Fill in the Description 
3. Fill in a Feature Code Number 
4. Choose the Auto Attendant IVR for the destination 
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Call the Feature code and test the IVR’s functions. 

Point Inbound Calls to Auto Attendant IVR 
Navigate to Core Configurations > Inbound Routes 

1. Click on Add Inbound Route 
2. Enter the DID number to match 
3. Set the destination to the new IVR 
4. Submit and Apply Config 
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Advanced Call Routing 
In addition to an IVR there are ways to route calls based on conditions.  This can be a manual change that is 

managed by a user to force calls between 2 destinations such as using a Call Flow Control, or you can route 

calls based on time and date by using a Time Group and Time Conditions. 

Call Flow Control 
A Call Flow Control (CFC) creates feature code that can toggle between two destinations.  The feature code is 

*28 followed by an instance number beginning with 0 so the first CFC will be *280.  There can be 10 CFC 

instances the last being *289.  The CFC can be enabled by directly dialing the feature code or it can be enabled 

by a using a BLF Button.   A hotel can use this for their front desk which they may want to ring different or 

additional extensions in the evening then just the front desk ring group used during the day.   Below we will 

create a CFC that will toggle between the Operator ring group and the MOD extension. 

Navigate to Advanced Configuration > Call Flow Control 

1. Click on Add 
2. Fill in the Description Field. (Night) 
3. Select the Normal (Green/BLF off) Button 
4. Enter a password if you would like to protect the CFC mode. 
5. Choose the destination of the normal call flow. (Operator)  
6. Choose the destination of the override. (MOD) 
7. Click on Save and Apply Config 
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Test Night Mode 

You can test activating and deactivating the CFC by dialing *280.  You can test the functionality of the CFC by 

creating a Misc Application that points to the Night CFC then dial the feature code number. While Night mode 

is activated and deactivated.   

 

Point Inbound Route to Night Mode 

Once the Night mode call flow control has been tested you can point an inbound route to the Night Mode CFC. 

Add Night Mode CFC BLF 

A BLF button can be added to a SIP phone to toggle the night Mode CFC on and off. 

Navigate to Devices > Endpoint Template Manager. 

Click on Edit for your phone template then click on The Keys Tab to add a BLF named Night. 

1. Type will be BLF 
2. Label will be Night 
3. Value will be *280 
4. Click on Save 
5. Click Extension Mappings in the Fly Away Menu 
6. Check the phones that need the update, then Rebuild and Reboot Phones  
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During Normal Flow the Night mode BLF button and label will be lit up red.  During Override mode the button light will 

be off and the label will have a green light.  Not all phones have labels that will behave this way. 

 

Time Based Routing 
Calls coming into the ComXchange Controller can be routed to different destinations based on Time 

Conditions.  Time Conditions work together with Time Groups or Calendars to define a time that calls will be 

routed to one place or another.  For instance, this may be set to dial the Operator Ring Group between the 

hours of 7 AM to 6 PM then dial the MOD phone outside of those times. 

Time Group 
A Time Group defines times to be used in a Time Condition.  Set up a Time Group defining Front Desk hours 

Navigate to Advanced Configuration > Time Groups 

1. Click Add Time Group 
2. Fill in the Description Field 
3. Specify the Time to Start 
4. Specify the Time to Finish 
5. Submit and Apply 
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Calendar 
A Calendar can be used to schedule times to be used in a time Condition by creating events. 

Navigate to Advanced Configuration > Calendars 

1. Click on Add Calendar 
2. Choose a Calendar type (local Calendar) 
3. Fill in the Name Field 
4. Fill in the Description Field 
5. Submit and Apply 
6. On the New Calendar click on the View Actions icon 
7. In the Calendar View Click on a Add Event or double click in the Calendar 
8. Fill in the Event Title Field 
9. Fill in the Description Field 
10. Specify the Time to Start 
11. Specify the Time to Finish 
12. Submit and Apply 
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Calendar Event Groups 
You can group times from multiple Calendars by creating a Calendar Group and adding multiple Calendars to it. 

Navigate to Advanced Configuration > Calendars 

1. Click on the Add Group Button 
2. Fill in the Name field 
3. Select the Calendars you want to include which can be further parsed by a category or event 

  

Time Conditions 

Time Condition with Time Group 

A Time Condition will define the routing for calls during or outside the times defined in a Time Group or a 

Calendar.  Below are the basic steps for setting up a Time Condition based on a Time Group. 

Navigate to Advanced Configuration > Time Conditions  

4. Click on the Add Time Condition Button 
5. Fill in the Time Condition Name field 
6. Choose Time Group for Mode  
7. Specify the Time Group in the Drop-down 
8. Choose the destination when the time matches 
9. Choose a destination when the time doesn’t match 
10. Submit and Apply 
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Time Group with a Calendar 

To Create a Time Condition with a Calendar you would choose the Calendar Mode in step 3 and the Calendar 

or a Calendar Group for Step 4. 

 

Creating a Time Condition also creates a feature code that allows you to override the current Time Condition 

and the normal flow will resume in the next transition.   You can test the Time Condition by pointing a Misc 

Application to it.  Once the Time Condition is tested you can set it as a destination for incoming calls.  A BLF 

button can be created to toggle the Time Condition on or off to override the normal schedule.   
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Follow Me 
Follow Me Allows you to redirect a call placed to an extension to another destination.  Calls received from ring 

groups or queues will not be redirected.  You can program the Follow Me to ring an extension alone for a 

certain amount of time and then ring a different destination like a mobile phone (a # suffix must be used to 

dial an external number) or a different extension.  There are also other ring strategies that can be used that 

are defined in the Ring Strategy Hint.  This feature can also be turned on and off with a BLF.  Create a Follow 

Me for the MOD extension to ring 7100 

Navigate to Core Configuration > Follow Me  

1. Enable the Follow Me on the extension on the right 
2. Click on the Extension you enabled on the on the Left 
3. Choose a ring strategy 
4. Add numbers to call in the Follow Me List 
5. Submit and Apply 
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The BLF Feature Code for Follow Me toggle is *74 followed by the extension.  For the MOD phone you can set 

up a BLF key to point to *747002 

 

 

Queues 
The Queues module is a more advanced version of a Ring Group.  Building a Queue creates an extension and a 

destination that when dialed will ring multiple extensions at the same time.  However, unlike a ring group, 

individual extensions added as Dynamic Members can be permitted to log in and out of the queue.  Members 

of a queue can also pause their membership.  A queue can be programmed to route calls to a single extension 

or to multiple extensions and can use various ring strategies.  While waiting in the queue the system can play 

Music on Hold and give the caller an option to exit the queue and be routed to another destination.  Calls can 

also time out and be routed to another destination. Below we will set up a queue for the hotels guest care line 

with two static and one dynamic agent. 

Navigate to Core Configuration > Queues 

1. Click on Add Queue 
2. In the General Settings tab enter a Queue Number in the Queue Number Field (650) 
3. Enter a Queue name in the Queue Name Field (Guest Care Line) 
4. Enter a CID Prefix (Care: so agents know it coming from the Guest Care Line) 
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5. Restrict Dynamic Agents 
6. Set Agent Restrictions 
7. Set a Failover Destination 

 

 
8. In the Queue Agents tab Select the desired Static Agents (7000 and 7001) 
9. Select Dynamic Agents (7002) 

 
10. In the Timing and Agent Options tab set a Max Wait Time of 5 minutes. (before being sent to a failover 

destination) 
11. Set Agent Timeout. (15 seconds is about 3 rings) 
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12. Auto Pause Options. (If set it will pause an agent if the agent doesn’t answer a queue call) 

  
13. You can set an IVR Breakout Menu and how often it repeats the IVR options. 
14. Submit Changes and Apply 

 

Dynamic Queue Members Login 
A Dynamic Queue Member can log in by dialing *45*<ext_no>*<queue_no>.  For example, Extension 7002 

would log in and out of queue 650 by dialing *45*7002*650.  This can be simplified by programming a BLF 
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button that dials the digits.  Dialing *45 only will log in or out of all queues of which the extension on the 

phone is a dynamic member. 

Queue Pause Activate / Deactivate 
Members can activate or deactivate a pause to a queue membership by dialing *46*<ext_no>*<queue_no>.  

For example, Extension 7002 would pause queue 650 membership by dialing *46*7002*650.  This can be 

simplified by programming a BLF button that dials the digits.  Dialing *46 only will activate or deactivate pause 

for all queues of which the extension on the phone is a dynamic member. 

Class of Service - Restricted Call Permissions / Staff or House phones 
ComXchange has six types of Class of Service types created by default.  These can be used on extensions that 

need restricted dialing enabled such as a house phone or a phone in a common area like a break room.  A 

Class of Service will allow very granular access to the dial plan.  A Class of Service can be applied to an 

extension in the Other tab - Class of Service section of the Extension. 

  

 

House Phone - Class of Service 
Navigate to Core Configuration > Class of Service 

1. Click on HousePhone edit Actions icon on the right side 
2. View the Staff Extensions tab 

a. This Class of Service will not allow a direct dial call to any Staff Extensions  
3. View Guest Extensions tab 
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a. This Class of Service will not allow a direct dial call to any Guest Extensions 
4. Outbound Routes tab 

a. This Class of Service will only allow outbound calls through the Emergency Trunk 
5. Feature Codes tab 

a. This Class of Service only allows a phone to dial the Operator Feature Code 0 
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Long Distance PIN 
You can also require an extension to dial a PIN when dialing long distance by creating a 2nd outbound route 

that requires a PIN and forcing the extension to use that route by modifying and using the restricted Class of 

Service.  You can also force a single extension or a group of extensions to use the route by using the CallerID 

field in the Outbound Routes Dial Patterns. 

Create a PIN Set 

Navigate to Advanced Configuration > PIN Sets 

1. Click the Add Pin Sets button 
2. Fill in the Pin Set Description field  
3. Add one or more PIN’s that can be used to authenticate a caller 
4. Submit and Apply 

 

 

Create a 2nd Long Distance Route 

Navigate to Core Configuration > Outbound Routes 

1. Click on the edit Actions icon for the LongDistance Outbound Route 
2. Duplicate Route. 
3. Click on the edit Actions icon of the newly Created LongDistance Route  
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4. Change the Route Name 
5. Under -Additional Settings choose the PIN Set that was previously created 
6. Submit Changes and Apply 
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Modify Class of Service -StaffRestricted 

Navigate to Advanced Configuration > Class of Service - Restricted 

1. Click on the edit Actions icon of the StaffRestricted Context 
2. On the Outbound Routes tab, add the LongDistance-Pin Outbound Route to the Allow group 
3. Submit and Apply 

 

 

Apply StaffRestricted Class of Service to the Extension 

Navigate to Core Configuration > Extensions 

1. Click on the edit Actions icon of the extension that you want to assign the Class of Service 
2. In the Other tab choose the StaffRestricted Class of Service from the dropdown 
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 Force a PIN with CallerID 

In the outbound route LongDistance-Pin you can add an extension or a wild card that will force any calls that 

match the pattern to use this route.  Below the Pattern in the Dial Pattern tab will match any 4-digit 

extensions that begin with 70 and only those extensions will use this route. 

 

Bulk Handler 
You can use the Bulk Handler Module to import Bulk Extension and Bulk DID’s, among other objects The Bulk 

Handler Module allows for CSV Export and Import of Extension Information, Inbound Routes, Blacklist 

numbers, Conferences, Contacts, and Users. 

Bulk Handler - Extensions 
You can export a current extensions CSV file from the ComXchange Server, modify it, then reload the modified 

CSV file to add many extensions very quickly.  If an email address is included in the extension that email will be 

notified of extension changes, you can place “noemail” in the Override Address to stop the notifications from 

being sent. 

Navigate to Admin > Bulk Handler 

1. Choose the Export Button 
2. Click on the Extensions Tab 
3. Click on Export 

a. Modify the downloaded file 
4. Click on the Import Button 
5. Browse to the modified file 
6. Click the Submit button 
7. Click the Import button 
8. Click the Finished button 
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Bulk DID’s 
You can download a current List of inbound DID routes from the ComXchange server, modify it, then reload 

the modified CSV file to add inbound DID routes very quickly. 

Navigate to Admin > Bulk Handler 

1. Choose the Export Button 
2. Click on the Extensions Tab 
3. Click on Export 

a. Modify the downloaded file 
4. Click on the Import Button 
5. Browse to the modified file 
6. Click the Submit button 
7. Click the Import button 
8. Click the Finished button 
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Conference Rooms 
A conference room is a single extension number that users can dial so they can talk to each other in a 

conference call.  It also creates a destination that calls can be sent to. 

Navigate to Core Configuration > Conferences. 

1. Click the Add Button 
2. Fill in the Conference Number field. 
3. Fill in the Conference Name field. 
4. Assign User and Admin PINs. 
5. Change the Leader Wait to Yes. 
6. Change Talker Optimization to Yes. 
7. Change Music on Hold to Yes. 
8. Change Allow Menu to Yes. 
9. Submit Changes and Apply. 

 

 

 

Music on Hold 
Music on Hold (MoH) allows the Hotel to play music to fill the silence when callers are placed on hold.  MoH 

can be used in Queues, Inbound Routes, Conference Rooms, ETC.  Customized MoH can be uploaded as .wav 

and .mp3 files, or you can create a category to use a streaming service. 
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Upload Wav or Mp3 
Navigate to Advanced Configuration > Music on Hold 

1. Click on the Add Music Button 
2. Fill in the Category Name field 
3. Click on Submit 
4. Click on the edit Actions icon for the new Category 
5. Click the Browse button and navigate to the file you want to upload or drag the file to the page 
6. Click on Submit 
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The new Category of music is ready and can be used for an Incoming Route, etc. 

 

Warning:  If you replace the wav_generic_moh.wav file in the reserved default category the wav_generic_moh.wav 

music file will be deleted from the system. 

Streaming Music on Hold 
Music on hold can also be supplied by a streaming music device. 

Navigate to Advanced Configuration > Music on Hold 

1. Click on the Add Category Button 
2. Fill in the Category Name field 
3. Choose Custom Application in the Type dropdown 
4. Click on Submit 
5. Click on the edit Actions icon for the new Category 
6. Fill in the Application Field in the format of: 

a. /usr/bin/mpg123 -q -r 8000 -f 8192 --mono -s http://<ip address>/xstream 

7. Click on Submit 
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To have a streaming service be used as a default MoH edit the default on hold music and choose Custom Application as 

the type then use the same string discussed above in the Application field 

 

Paging 
Allows the setup of a group of phones that will auto answer a call made to the paging extension.  This requires 

SIP auto answer which doesn’t work on most soft phones. 

Navigate to Advanced Configuration > Paging and Intercom. 

1. Click on Add Page Group Button 
2. Fill in the Paging Extension Field  
3. Fill in the Group Description Field 
4. Click in the Device List and check the extensions to be part of the group  
5. Choose what to do if the Extension is busy  
6. Submit and Apply 
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Logs / Reports 
ComXchange has built in logging and reports that are valuable to monitor the system or for help with 

troubleshooting issues with making or receiving calls.  The reports can give information on registered 

extensions and trunks as well as provide access to the asterisk and call logs.    

Asterisk Info 
The Asterisk Summary Page will open with a brief chart of the Asterisk Uptime, Active SIP Channels, SIP 

Registries, and SIP Peer Status.  There are many other reports such as SIP Peers that will list the SIP 

Name/Username and whether they are registered or not with an IP address. 

Navigate to Reports > Asterisk Info  

Summary 

 

SIP Peers 

The peers report will now have both the staff and the guest extensions 
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SIP Registry 

 

Asterisk Logfiles 
The Asterisk Log files can provide details into a call’s events.  In the examples below you can see the logs for 

the Full Log and the Fail2ban Log. 

Navigate to Reports > Asterisk Logfiles 

Full Log 
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Fail2Ban Log 

 

 

CDR Reports 
The CDR Reports allow you to view or download a report of calls made and received by ComXchange.  There 

are many options to search and filter by including Date, Date Range, Number Called, Caller ID, etc.   

Navigate to Reports > CDR Reports  

Place your search criteria and click on Search. 

 

You can click on the links under system to see more details. 
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Call Event Logging 
The CEL Reports is a Beta module that will allow you to view the detailed events of calls made and received by 

ComXchange.  The information is similar-to the information found when you click on the system link found in a 

CDR record but can be searched based on the source and destination digits.  

Navigate to Reports > Call Event Logging 
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Click on the Show button of the call to see details such as Context, and Channel Name 

 

Print Extensions 
The Print Extensions report can be used to easily verify extensions, feature codes, and other call destinations. 

Navigate to Reports > Print Extensions 
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System Dashboard  
The System Dashboard is the default log in page of the ComXchange Phone System.  The page displays Server 

Uptime, Status and Statistics.  

Navigate to Report > Dashboard 

 

BACKUP & RESTORE 
The ComXchange Phone System comes with 2 default backup jobs running that will perform a full backup of 

the ComXchange server and one that backs up the call accounting data.  Backups are stored on the local hard 

drive as well as a local USB Storage Drive.  Other backup destinations can be set by customizing the backup 

job.  The backup is set to run daily and will save 7 backups, removing the oldest. 

Performing a Backup on Demand 
Navigate to Admin > Backup and Restore. 

1. Click on the Call Accounting or PBX backup that job that you want to run 
2. Click on the Save and Run button at the bottom of the page to perform a backup 
3. Close the Backup Successful dialogue box 

 

 



85 
COMXCHANGE 14 

Restore from a Backup 
 Navigate to Admin > Backup and Restore. 

1. Click on the fly out menu on the right-side 
2. Click on Restore 
3. Click on the Brose Tab (or import from a file) 
4. Click on Local Storage or USB in the right-side menu. 
5. Expand the Backup Job folder and choose the backup file. 
6. Click on Go. 
7. Select the items to restore. 
8. Click on restore. 

 

 

  

User Mangement 
The User Management Module is where you manage user’s passwords and permissions for other modules like 

Call Accounting and UCP.  Users are automatically created and associated with an extension when an 

extension is made. You can also create users that aren’t attached to an extension to do managerial activities in 

Call Accounting and the Hotel Dashboard.  Below we will make changes to allow a user to log into the User 

Control Panel. 

Navigate to Admin > User Management - Users 

Users 
1. Click on the edit Action icon for the extension that you want to grant access to the UCP 
2. Change the password to a default password for the user to log in with 

a. Note this is where you can see the Primary Linked Extension 
3. The Call Accounting tab is where you allow access and permissions to the Call Accounting features 
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a. Typically, you will set this up for a user that isn’t linked to an extension 
4. UCP tab is where you would enable access and grant permissions for a user to access their UCP and 

manage their extensions features like voicemail and call history 
5. Set the Allow Login to Yes 

a. Once the user is granted access, they should be able to access the UCP features 

 

 

 

In the UCP tab you can give users access to other extensions for example below User 7002 will be allowed to 

access the Call History for extension 7000, 7001, and 7002. 
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Groups 
Can be used to put users with similar permissions together.  By default, there is an All Users group that all new 

users (with or without an extension) is added to.  This Group defines the default permissions that are assigned 

to these users at creation.  

Navigate to Admin > User Management – Groups 

Click on the edit Action icon to view the default permissions that Users of this group will be assigned 

 

 

You can also change what features are accessible to the users by default. 

 

User Control Panel 
The User Control Panel is a web menu that allows users to do some basic management of their extension.  The 

User logs in by typing “http://< LAN IP address of the ComXchange>/ucp” into the address bar of a web 

browser.  Or an easier method for users to access it is to create a desktop shortcut with the location of 

http://192.168.101.2/ucp which will directly open the login page.  The User Control Panel allows users to log 
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into a portal with their extension (by default) and password set in the User Management Module.  In the UCP 

users can set up a dashboard and add widgets that allow them to see the Extensions call history, listen to and 

manage their Voicemail, setup Follow Me rules, Call forwarding, and other settings.  Users must first be set up 

in the User Management Module to be allowed to log in to the UCP. 

UCP Login 
1. Navigate to the web login by entering http:192.168.101.2/ucp  
2. Enter the user credentials and password  
3. Click Login 

 

 

Create a UCP Dashboard 
1. Click on add a Dashboard 
2. Fill in Dashboard Name 
3. Click Create Dashboard 

 

UCP Widgets 
Once a dashboard is created a user can add Widgets to access different functions.  To add the different 

functions Click on the Add a Widget Button on the dashboard. 
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Call Accounting Widget 

The Call Accounting Widget adds a link to Launch the Call Accounting Module for ComX14. 

  

Call Forwarding Widget 

The Call Forwarding Widget allows a User to control the forwarding functionality of the extension.  This can be 

set as unconditional (always forwarding), Unavailable (if the phone endpoint becomes unresponsive), and 

Busy (if the Extension has an active call). 

  

Call Waiting Widget 

The Call Waiting Widget controls whether Call Waiting is enabled or disabled for an extension. 
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Call History 

The Call History Widget allows a User to view and search for calls and listen to recorded calls to and from the 

Extension(s) that the user is given access to in the UCP section for the user in the User Management Module.  

Below User 7002 has access to both Front Desk extensions. 

 

 

Call Events Widget 

The Call Events Widget allows a user view the Date, Caller, Dialed Number, and Duration of a call. 
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Do Not Disturb 

The Do not Disturb Widget allows the User to control the endpoints DND functionality. 

  

Follow Me Widget 

The Follow Me Widget allows an incoming call to an extension to be received on multiple phones.  Once added 

the user can program the Follow Me functionality by clicking on the settings cog wheel icon. 
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Voicemail Widget 
This menu allows a user to manage and listen to their voicemail through a web interface.  The User can also 

control some of the Voicemail settings by clicking the settings cog wheel  

 

 

Voicemail Settings 
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Hotel Dashboard Widget 

The Hotel Dashboard Widget adds a link to Launch the Call Accounting Module for ComX14. 

  

Call Accounting Setup 
The Call Accounting module is used to configure the Call Accounting Server.  The Call Accounting Server has 

two interfaces that can be configured to receive data from the PBX’s SMDR interface, process that 

information, then send data out the PMS interface to the PMS Systems to charge billable phone calls to guests 

of the hotel.  The call accounting must be licensed and the V&H file (Vertical and Horizontal file used to assess 

the distance between two points for call rating) must be ordered and delivered from 360 Networks before 

setup can begin.  Below are the basic steps to install the V&H files and prepare the Call Accounting Server 

module to interface with a PMS system. 

Navigate to Reports > Call Accounting 

This will open to a recent call summary page.  To open the Call Accounting Settings, click on the Admin Button. 

 

You can expand all options by clicking on the Show More button. 



94 
COMXCHANGE 14 

 

Call Accounting Interfaces 

 

There are two interfaces that can be configured in the Call Accounting Module.  The first is the interface between the 

PBX and the Call Accounting Server which should never need to be changed as it is set up to receive the SMDR 

information from the PBX by default.  The second is the interface between the Call Accounting Server and the PMS 

System.  This interface may need to be changed based on the PMS vendor. 

 



95 
COMXCHANGE 14 

 

Add Local Numbers 
Add the Local Number NPA (Number Plan Area) and exchange Information.  This will be the area code and three 

numbers directly after the area code. 

1. Click on the PBX Button 

2. Add the Area Code in the NPA field 

3. Add the exchange numbers in the ABC field 

4. Click on the Save Changes Button 

5. Click on Update Settings 
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Import V&H File 
1. Click on V&H Import Button 
2. Click on the Upload File Button 
3. In the popup navigate to the VhData.est file 
4. Click on Import 
5. Wait for the File to process. 
6. When finished Click on Update Settings 

 

 

 

Import stations 
In-order-for calls to be processed the Call Accounting must be made aware of the stations (extensions) in ComXchange. 

1. Click on the Stations Button 
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2. Click on the Import Stations From ComXchange Button 

 

Test Call 
To verify that the Call Accounting Module is configured to price calls use the test call feature to simulate a call. 

1. Click on the Test Call Button 
2. Choose a station to test from in the dropdown box 
3. Click Post to PMS if you want to send the call information over the PMS connection 
4. Click on the Current Date Button 
5. Click on the Current Time Button 
6. Enter a phone number in the Dialed Digits Field 
7. Enter a Call duration (must be more than 2 minutes) 
8. Click on Sumit 
9. View the results 
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To monitor the information that is being sent out from the call accounting module Click on the Data Monitor Button 

while a test call is being sent to the PMS. 

 

Staff Access to Call Accounting 
To Staff to access the Call Accounting reports and VIP rooms that won’t be charged you need a user that has 

access to the UCP and permissions for the Call Accounting Module.  While this can be an extension User that is 

given access in the example below, we will create a User that is used to access the Call Accounting Module.  

(Note: This HotelUser was created earlier for accessing the Hotel Dashboard.) 

Navigate to Admin > User Management 

1. Choose any extension and click on the edit Action icon 
2. Click on and open the Flyout Menu  
3. Click on the Add User Button 
4. Fill in the Login Name 
5. Fill in a Password 
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6. Submit and Apply 
7. Click on the edit Action icon of the new user 
8. In the UCP tab click on the Yes button to allow Login 
9. Click on the Call Accounting Tab and Assign permissions for the user 
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Log into the UCP at 192.168.101.2/UCP and Click on the Call Accounting Link or use the Call Accounting Widget to 

Launch the Call Accounting Module. 

 

The User now has privileges to view, create, and schedule reports as well as the ability to mark Rooms as VIP’s. 
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